Cocoapods以及Facebook Pop的安装

2017-01-14 10:46:36来源:http://www.jianshu.com/p/d5a550fdf24a作者:夏亦流风人点击

一、查看Ruby版本(命令:$ ruby -version)。

--版本低于2.2是不行的,使用rvm升级Ruby($ rvm install 2.3)。 

二、切换镜像。

1、移除现有Ruby默认源。

$ gem sources --remove https://rubygems.org/

2、使用新的源。

$ gem sources -a https://ruby.taobao.org/

3、验证是否成功。

$ gem sources -l

显示出下面文案即可。

*** CURRENT SOURCES ***

https://ruby.taobao.org/

三、开始安装。

$ sudo gem install -n /usr/local/bin cocoapods(神坑,Mac OS X 10.11以上版本需要使用这条命令)

$ pod setup(漫长的等待,开VPN下载了865M才结束)

期间可以使用命令:$ cd ~/.cocoapods/,进入cocoapods文件夹,然后使用命令:$ du -sh *,既可查看下载大小。

四、Pop安装。

1、进入项目文件目录,vim Podfile,然后输入下面内容。(第二行是项目名称,第三行是要引进的库)

platform :ios, '8.0'

target 'PopDemo' do

pod 'pop', '~> 1.0'

end

编辑完成后,按ESC退出编辑模式,最后输入:wq保存并退出文件,并在该目录下直接执行命令:pod install。

2、安装完成后,打开PopDemo.xcworkspace即可。

五、如果过程出现了其他问题,删掉,重头再来。

--$ sudo gem uninstall cocoapods




最新文章

123

最新摄影

微信扫一扫

第七城市微信公众平台