win7_64下postgresql编译

2016-07-12 10:26:09来源:oschina作者:longhai123人点击

1、flex&bison安装


本着我自己去找官网什么的老是打不开啊神马的,然后下源码什么的安装还是linux玩的溜,所以直接把我的打包放上来,解压就能用(如果自己去找找网站研究一下其实收获会更大),不要放到Program Files或者Program Files (x86)路径下啊,有空格的话会有各种problem。参考路径:D:/GnuWin32,然后把环境变量加上(这个不知道的就百度一下咯)。


检验方式直接上图算了:



http://pan.baidu.com/s/1wUfTW

2、perl安装


perl的官网还是很好找的,百度就能找到。但是经过我的试验哈,我现在写这篇文章的时候5.22版本貌似不好使,编译的时候会出现很多的宏未找到的错误,所以推荐5.20的版本,但是我在写这篇文章的时候呢5.20版本的win64位官网是不能下载的(点背),所以其他地方找了一个,网盘也奉上算了。


http://pan.baidu.com/s/1dDdlhXR


打开cmd,然后perl --version可以查看安装是否正确。


干货:假如安装的第一个perl版本编译的时候出现那个很多宏找不到的错误,好,更换perl版本,这时候记得在编译之前使用clean.bat把原来编译出来的一些东西清除掉,免得下次还是会报错。(本人也一度没有注意这个东东,perl版本从5.22-5.18-5.20,我估计5.18也好使,留给有心人去验证了哈。)


3、vs2008安装


本人绝对是个好人,直接安装包再来,免去您老到处寻找的痛苦:


http://pan.baidu.com/s/1c0sgqPi


安装时选择“完全”吧,作为一个开发人员,电脑至少得说的过去吧,资源浪费在学习工具上是值得的。电脑实在带不起的话,果断砸了,换新的!


4、编译



打开如图命令提示,cd /d E:/postgresql-9.4.4/src/tools/msvc进入目录,perl build.pl DEBUG进行编译

Unable to determine Visual Studio version: The nmake version could not be determined. at src/tools/msvc/Mkvcbuild.pm line 63.

提示找不到vs版本,解决方案:

E:/postgresql-9.4.4/src/tools/msvc/VSObjectFactory.pm中CreateSolution函数第二行直接添加return new VS2008Solution(@_);【其中的2008根据具体情况而定,你要是安装的vs2010,这个填写2010】

E:/postgresql-9.4.4/src/tools/msvc/Mkvcbuild.pm修改如下:


忘了截图了,真是个悲剧,偷个懒就不恢复错误环境截出现problen的图了,反正就是很多的宏找不到的problen。譬如这样的,出现50多个这个的错误吧:TRACE_POSTGRESQL_MULTIXACT_CHECKPOINT_DONE

这个problem呢,就是perl版本problem,更换perl版本,记得clean.bat一下先!(上面已经说过了,重要的事情说了第二遍!)


请耐心等待。。。

好了,成功一般都是报11个警告(pg944,等亲爱的你看到这篇文章的时候可能版本又不一样了,警告个数不同了也不一定,可以不管),这时候所有的vs工程也都编译出来啦,熟悉了吧。看见sln应该安心了呀~



5、安装


简单:


install.bat 目的地


例如



最后再说一遍,clean.bat这个还是可以经常试试的,在编译过程中假如出错了的话(重要的事情说三遍!这是写这篇文章时下比较流行的网络语,有可能你看的时候早就没人记得这句话了,时光荏苒啊)。


最后再说一句,本文中之所以用了好多的problem,并非作者装逼,而是因为文中不同各处出现考、试、ti三个字,竟然提醒文中包含敏感文字不让发表,真真醉了!


最新文章

123

最新摄影

微信扫一扫

第七城市微信公众平台