perl 安装模块

2016-08-21 11:47:29来源:CSDN作者:qianggezhishen人点击

有时候,我们在执行 perl 脚本的时候,经常会出现某个模块没有安装的情况,比如会出现类似的错误:

Can't locate HTTP/Request/Common.pm in @INC (you may need to install the HTTP::Request::Common module) (@INC contains: /etc/perl /usr/local/lib/perl/5.18.2 /usr/local/share/perl/5.18.2 /usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.18 /usr/share/perl/5.18 /usr/local/lib/site_perl .) at ./jvpn.pl line 22.

BEGIN failed–compilation aborted at ./jvpn.pl line 22.

这就说明我们需要安装 HTTP::Request::Common module ,那么我们可以如下操作:

在终端中输入

#cpan

如果不行,则输入

#perl -MCPAN -e "shell"

然后出现 cpan> 提示符后,输入命令

install HTTP::Request::Common

系统就会自动寻找合适的镜像站点,从网络安装HTTP::Request::Common.

如此,缺少什么就安装什么

再编译或运行,程序就可以了。

最新文章

123

最新摄影

微信扫一扫

第七城市微信公众平台