nginx版本升级问题

2016-09-02 10:58:19来源:oschina作者:saintli86人点击

安装/升级 nginx之后,启动nginx ,报以下错误: nginx: [alert] version 1.4.0 of nginx.pm is required, but 1.2.0 was found 二.问题定位 find nginx.pm发现,这个perl文件,在make install的时候,也会安装,如果不指定安装目录,这个文件会默认安装到/usr/local/lib64/perl5/nginx.pm。 而nginx.pm里面记录了nginx的版本号。所以,如果启动nginx的时候,运行的nginx与nginx.pm版本号不一致就有问题,特别是升级nginx,或者一台机器上部署了多个nginx。 三.问题解决 编译安装,指定 --with-perl_modules_path=/home/webserver/nginx3/perl 这样会把相关perl程序/模块 安装到具体目录里。

最新文章

123

最新摄影

微信扫一扫

第七城市微信公众平台