学习注水-20161108-Perl: Can't locate XML:LibXML

2016-11-09 08:18:30来源:CSDN作者:u012251305人点击

Problem

  1. Can’t locate XML/LibXML.pm in @INC (you may need to install the XML::LibXML module) (@INC contains: /etc/perl /usr/local/lib/perl/5.18.2 /usr/local/share/perl/5.18.2 /usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.18 /usr/share/perl/5.18 /usr/local/lib/site_perl .) at parser.pl line 29. BEGIN failed–compilation aborted at parser.pl line 29.
  2. Expat.xs:12:19: fatal error: expat.h: No such file or directory

Solution

sudo apt-get install libexpat1-dev # 参考中缺这一条命令sudo apt-get install libxml2-dev zlib1g-devsudo cpan install XML::Simplesudo cpan install XML::LibXML

References

Can’t locate XML/LibXML.pm in @INC

最新文章

123

最新摄影

微信扫一扫

第七城市微信公众平台