Centos 6.5 下GBrowse 2.0安装(详细版)

2017-08-03 20:09:04来源:CSDN作者:bianenze人点击

分享

1.查看系统自带的perl版本

 perl -v

提示:This is perl, v5.10.1 (*) built for x86_64-linux-thread-multi
显然这个系统自带的perl版本较低,我们需要更换高版本的perl,因为如果用低级版本的perl后边加载的依赖也是低版本。
例如:
centos 7自带的perl 的DG模块是2.49,而GBrowse需要>=2.50。

2.卸载自带的 perl

 yum remove perl y 回车 此时输入perl -v 发现no such file 表示卸载成功

3.安装新版本的perl

 下载地址:http://www.cpan.org/src/5.0/perl-5.26.0.tar.gz tar -zxvf perl-5.26.0.tar.gz cd perl-5.26.0 ./Configure -des -Dusethreads -Dprefix=/usr/local/perl make make test make install //这三个命令要依次都执行而且在要在perl-5.26.0目录下 //此过程较慢耐心等待 完成后输入 perl -v

出现提示:This is perl 5, version 26, subversion 0 (v5.26.0) built for x86_64-linux-thread-multi 表示成功!

4.安装git,下载项目程序

 因为要从github上获取项目资源,而系统默认没有装git 输入 yum install git 一路y回车即可

输入:git clone git://github.com/GMOD/GBrowse.git 下载项目到当前路径下

5.安装cpan和依赖

 sudo yum -y install perl-CPAN  cpan -i Algorithm::Diff Class::Singleton DBI DBD::mysql Log::Dispatch Log::Log4perl     Mail::Send Net::Ping Proc::Daemon Time::HiRes Params::Validate Net::ARP

一路回车
又是个漫长的过程……
最后出现ok完成
下面很关键了:

先安装 yum install gd-devel     //这个一定要先安装,不然GD模块装不上输入:cpan                      //进入cpan终端输入:install GD Module::Build IO::String Capture::Tiny CGI::Session JSON JSON::Any libwww::perl DBD::SQLite File::NFSLock Net::SMTP::SSL Crypt::SSLeay Net::SSLeay Template::Toolkit Bio::Perl Bio::Graphics GD DBD::mysql GD::SVG DBI DBD::Pg Digest::MD5 Statistics::Descriptive Template

一路回车
依旧是个漫长的过程……
最后回到命令行,过程中有些模块可能缺少依赖没装上
输入exit退出
在GBrosers路径下
输入 perl Build.PL
这块很关键!!!
这块我们通过输出的信息可以看到哪些模块没有装上,还有哪些模块推荐安装
例如这是必须安装的:
这里写图片描述
这里发现利用cpan安装模块,这些没有装上,我们利用yum补全
首先安装
yum install perl-libwww-perl
yum install perl-CGI-Session
yum install perl-TermReadKey
最后剩一个Bio::Graphics
这个得在前三个装上以后再利用cpan安装
输入cpan
输入install Bio::Graphics
安装完,此时exit退出
再次输入 perl Build.PL
此时应该requires没有了
那么所有的准备工作基本要结束

6.安装GBrowse

 在GBrowse路径下 输入 ./Build test 注意看它默认端口号是不是80,如果不是改成80(一般第一次都是默认80) 然后回车即可 在输入 ./Build demo 一路回车 在输入 ./Build install 一路回车

最后我们看到
INSTALLATION COMPLETE
Load http://localhost/gbrowse2 for demo and documentation.
Visit the http://gmod.org for more information on setting up databases for users and custom tracks.

于是我们满心欢喜的去点开这个链接,最后发现无法连接
这是因为我们的apche服务没有开启
在终端输入
httpd -k start
然后打开链接即可
然后打开
http://your.host/cgi-bin/gb2/gbrowse/yeast (simple example)

如果发现错误(一般不会有吧……)
那么可能是在var/www/路径下的cgi-bin文件夹缺少
可以把/usr/local/apache/cgi-bin 直接考过了
ps:具体问题具体分析了

到此全部结束……

网上关于GBrowse的安装都是一样的,亲测没能成功,无奈之下自己摸索出来的,有什么问题还可以联系我。

最新文章

123

最新摄影

闪念基因

微信扫一扫

第七城市微信公众平台