关于vscode编写python3,Django2.0时,pylint不能正常使用的问题

2017-12-27 19:07:20来源:cnblogs.com作者:c_night人点击

分享

使用vscode编写Django2.0项目的时候,安装的pylint会报错

由于vscode和系统默认的python是python2,而Django2.0不支持python2,默认使用python3,导致pylint不能正确的使用

解决办法:

1)卸载掉pylint:sudo pip uninstall pylint

  windows中请执行pip uninstall pylint,若出错,请以管理员方式打开终端(不确定是否必须)

2)重新以python3安装pylint:sudo pip3 install pylint

  windows中请以管理员方式打开终端,执行pip3 install pylint

3)打开vscode,修改相应设置:(windows10 ,ubuntu16.04)

  1.文件->首选项->设置 (英文版对应:file -> preferences -> settings)

  2.折叠常用设置(Commonly Uesd),展开Python Configuration,找到下图中pylintArgs一项。或直接搜索pylintArgs

  3.鼠标移动到上面,会在左侧出现一个笔符号,点击,复制到设置(copy to settings)

  4.在括号中添加指令。取消提醒,可添加”–disable-msg=C0103”。不同指令/错误代号逗号分隔。

 

  5.同操作2,在搜索里面搜:python.pythonpath,并且执行操作3

  6.在右边的修改python为python3即可

之后重启vscode  发现pylint工作正常

微信扫一扫

第七城市微信公众平台