vim install clang_complete

2018-01-12 11:15:23来源:oschina作者:SLonger人点击

分享

环境:vim7.4需要支持python
ubuntu 16.04
使用vim-plugin 进行管理
安装:
1) 在.vimrc 中添加: Plug 'Rip-Rip/clang_complete'
2)安装 libclang库 比如:/usr/lib64/libclang.so.3.8(apt search libclang查看可使用libclang 库)
.vimrc中添加: let g:clang_library_path='/usr/lib64/libclang.so.3.8'
3)编写一个.c文件 出现:Libclang can not find the builtin includes. 这个问题:安装对应的 clang头文件(apt search clang查看可使用头文件库):比如 sudo apt-get install clang-3.8 安装完成后应该就没有问题了, 如果还是出现这个问题, 请看(https://github.com/Rip-Rip/clang_complete/issues/238)解决。

最新文章

123

最新摄影

微信扫一扫

第七城市微信公众平台