安装cocoapods时出现的错误

2016-10-19 11:41:39来源:CSDN作者:wwc455634698人点击

安装cocoapods时出现的错误:

换了个mac本,在上面安装 cocoapods时,输入了sudo gem install cocoapods命后,结果出现了一句话:Error installing pods:activesupport requires Ruby version >= 2.2.2.这句话的意思就是:你要安装 cocoapods.你的 Ruby环境版本必须大于等于2.2.2.  好吧,只有更新了。


1.安装rvm(就是Ruby版本管理器)

首先打开终端,输入这句命令:

$ curl -L get.rvm.io | bash -s stable


等一会就安装好了,输入下面这句命令,测试安装是否正常:

rvm -v

会出现bogon:~ yanshujun$ rvm -v

rvm 1.27.0 (latest) by Wayne E. Seguin <wayneeseguin@gmail.com>, Michal Papis <mpapis@gmail.com,这就对了


2.升级Ruby

你可以输入下面这句命令,查看当前ruby版本  

$ ruby -v  

  

输入下面这句命令,列出已知的ruby版本  

$ rvm list known 

 

让后就是安装ruby的新版本,我选择的是2.2.4 

$ rvm install 2.2.4

我开始选的是ruby的2.3版本,结果出现了下面的错误:Searching for binary rubies, this might take some time.

No binary rubies available for: osx/10.11/x86_64/ruby-2.3.1.

Continuing with compilation. Please read 'rvm help mount' to get more information on binary rubies.

Checking requirements for osx.




3.安装 cocoapods 

接下来在终端输入下面这句命令:

sudo gem install cocoapods 

最新文章

123

最新摄影

微信扫一扫

第七城市微信公众平台