Mac下升级ruby至最新版本

2016-10-22 22:18:29来源:CSDN作者:spring21st人点击

升级ruby

Mac OS自身安装的有ruby,但是版本较低,为2.0.x
而安装CocoaPods,最低版本是2.2

查看ruby版本

ruby --version

安装homebrew

ruby -e "$(curl -fsSL https://raw.github.com/Homebrew/homebrew/go/install)"

通过 brew 安装 Ruby 最新版本

通过brew进行安装升级ruby

brew updatebrew install ruby

再次查看ruby版本

ruby --version

如果还是2.0,查看ruby环境变量路径which ruby,
如果不是/usr/local/bin/ruby,则需要将通过brew升级的ruby添加至环境变量

添加ruby至环境变量

vim .profilevim .bashrcvim .bash_profile

重启source

source .profilesource .bash_profile

最新文章

123

最新摄影

微信扫一扫

第七城市微信公众平台