mac 10.11以后安装CocoaPods教程

2016-10-23 10:14:33来源:CSDN作者:lanshiliulb人点击

第七城市

一、在进行CococaPods安装的时候,遇到错误,错误提示大致意思是ruby版本太低,需要升级至2.2.2以上.果然,在终端使用ruby -v查看版本为2.0.

1、使用RVM也就是Ruby Version Manager,Ruby版本管理器来升级rubyRVM包含了Ruby的版本管理和Gem库管理(gemset)。(一下命令在一切都在终端中进行,因为基本都是命令行  我就不上图了,终端的提示也比较清晰)

#1  RVM安装

       $ curl -L get.rvm.io | bash -s stable

# 2  之后就是等待一段时间之后,就可以安装成功了,使用以下命令来验证

        $ source ~/.bashrc

        $ source ~/.bash_profile

# 3 测试是否安装正常

        $ rvm -v

如果出现rvm(版本号)........<waynesseguin@gmail.com>......基本就算是安装RVM成功了。

2、使用RVM升级Ruby

#1、查看当前ruby版本

 $ ruby -v

这一步会显示出来当前ruby的版本

#2、列出已知ruby的版本

$ rvm list known

稍等一下,会出现很多平台不同的ruby的版本,我因为是需要2.2.2以上的版本,所以直接安装2.2.4版本

#3、安装ruby 2.2.4

$ rvm install 2.2.4

#4、安装完之后,可以ruby -v 测试一下,看看版本有没有变化PS:首先说明一下,在这一步,需要按回车键,连续按几次,当然如果你没装xcode,需要先去装xcode,不然会报错,接下来就是按常规的方法安装CocoaPods了!


二、CocoaPods安装:

1、我们可以通过淘宝的Ruby镜像来访问cocoapods;

gem sources --remove

// (移除以前安装的库,如果以前没有安装,可以不用敲)等到终端有反应之后再敲入一下命令,根据网速快慢,等待时间不同,可能一分钟也可能五分钟

gem sources --add https://ruby.taobao.org/  

//注意:链接是https 不是 http !!!


2、验证是不是淘宝镜像:

gem sources -l

成功后会显示:

Pasted Graphic.tiff

3、这时候在终端运行下一句代码:

sudo gem install cocoapods

//接下来就是等待终端响应,根据网速不同,有的一分钟,有的五分钟;

安装完毕后会有如下显示:

Pasted Graphic 1.tiff


4、然后再运行以下代码:

pod setup

但是在运行pod setup代码是可能会出现三中的问题;


在安装cocoapods(执行pod setup命令时)遇到的问题

 [!] /usr/bin/git clone https://github.com/CocoaPods/Specs.git master

Cloning into 'master'...

error: RPC failed; curl 56 SSLRead()return error -36

fatal: The remote end hung up unexpectedly

fatal: early EOF

fatal: index-pack failed


解决方案: 

打开终端命令行,输入一下命令:

sudo xcode-select -switch /Applications/Xcode.app/Contents/Developer


并一定是这行代码,要根据自己的情况,来修改这个命令行 

1、当然一个xcode执行这行肯定没问题 

20160706170316410.jpg 

2、也许你是多个xcode 

20160706170020252.jpg 

那么你的命令行就要修改一下:

sudo xcode-select -switch /Applications/Xcode7.3.1.app/Contents/Developer


根据你默认的xcode来修改在/Applications//Contents/Developer中间的app的名字,如果你默认的是Xcode x.x.x.app,中间就要替换掉哟!

ps:问题还存在,把xcode全部卸载,只装一个最新的。

3、最简便的方式是: 

先在终端输入”sudo xcode-select -switch “,然后,打开Xcode—>右键显示包内容,找到Developer文件夹拖到终端里面

PS:一些xcode-select的命令的使用:

xcode-select [-help]

xcode-select [-switch xcode_folder_path]

xcode-select [-print-path]

xcode-select [-version]


例如: 

打印当前xcode的路径

xcode-select--print-path


输出:

/Applications/Xcode.app/Contents/Developer

第七城市

最新文章

123

最新摄影

微信扫一扫

第七城市微信公众平台