安装cocopods时失败,更新ruby到2.2.2失败原因

2016-10-28 11:29:21来源:CSDN作者:SMoothiemiss人点击

第七城市

安装cocopods时失败,更新ruby到2.2.2失败原因

今天安装cocopods失败了,终端上说ruby的版本太低了了需要更新到ruby2.2.2版本

http://blog.csdn.net/lissdy/article/details/9191351

看上面这个网站更新ruby到指定版本,然后就报错了下面是错误代码

错误代码

Error running 'requirements_osx_brew_libs_install autoconf automake libtool pkg-config libyaml readline libksba openssl',showing last 15 lines of /Users/junge/.rvm/log/1477380049_ruby-2.3.0/package_install_autoconf_automake_libtool_pkg-config_libyaml_readline_libksba_openssl.log++ case "$1" in++ [[ -t 1 ]]++ return 1++ printf %b 'There were package installation errors, make sure to read the log.Try `brew tap --repair` and make sure `brew doctor` looks reasonable.Check Homebrew requirements https://github.com/Homebrew/homebrew/wiki/Installation/n'There were package installation errors, make sure to read the log.Try `brew tap --repair` and make sure `brew doctor` looks reasonable.Check Homebrew requirements https://github.com/Homebrew/homebrew/wiki/Installation++ case "$_system_version" in++ return 1Requirements installation failed with status: 1.

在stackoverflow上面找了好久终于找到类似的答案,可能就是网络的问题,因为下载ruby的时候要下载相关的包

Installing requirements for osx.
Updating system…..
Installing required packages: autoconf, automake, libtool, pkg-config, libyaml, readline, libksba, openssl…..

下载这些包可能要翻墙,没办法翻墙试了一下果然成功了

Certificates in '/usr/local/etc/openssl/cert.pem' are already up to date.Requirements installation successful.ruby-2.2.2 - #configureruby-2.2.2 - #download  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current                                 Dload  Upload   Total   Spent    Left  Speed100 6854k  100 6854k    0     0  11540      0  0:10:08  0:10:08 --:--:-- 74959ruby-2.2.2 - #validate archiveruby-2.2.2 - #extractruby-2.2.2 - #validate binaryruby-2.2.2 - #setupruby-2.2.2 - #gemset created /Users/junge/.rvm/gems/ruby-2.2.2@globalruby-2.2.2 - #importing gemset /Users/junge/.rvm/gemsets/global.gems..................-ruby-2.2.2 - #generating global wrappers........ruby-2.2.2 - #gemset created /Users/junge/.rvm/gems/ruby-2.2.2ruby-2.2.2 - #importing gemsetfile /Users/junge/.rvm/gemsets/default.gems evaluated to empty gem listruby-2.2.2 - #generating default wrappers........Updating certificates in '/etc/openssl/cert.pem'.mkdir: /etc/openssl: Permission deniedmkdir -p "/etc/openssl" failed, retrying with sudojunge password required for 'mkdir -p /etc/openssl': and sudo mkdir workedjungedeMac-mini:~ junge$ ruby -vruby 2.2.2p95 (2015-04-13 revision 50295) [x86_64-darwin14]jungedeMac-mini:~ junge$ 

给大家推荐一个macvpn下载地址,可以免费使用,但是好像要注册。简单注册就能能用了。
http://www.vpn123.co/download

第七城市

最新文章

123

最新摄影

微信扫一扫

第七城市微信公众平台