windows下安装ruby on rails出现问题的解决办法

2016-10-31 19:04:10来源:CSDN作者:javaer_lee人点击

windows平台下用gem install rails会出现以下错误:


'websocket-driver' native gem requires installed build tools

Please update your PATH to include build tools or download the DevKit





解决方案:

1、下载DevKit

    DevKit-tdm-32-4.5.2-20110712-1620-sfx.exe

 

2、解压DevKit

    解压到C:/DevKit


3、安装

      cd到解压目录下:

执行如下命令

C:/DevKit>ruby dk.rb init

执行完后会生成一个  config.yml 文件

在文件最后输入以下内容:

---
- C:/Ruby23-x64             //这个路径为ruby的安装路径


注意前面的横线,必须要加上

--- indicates a document header, and the - indicates a member of a sequence or list


修改完config.yml文件后继续执行以下命令:

C:/DevKit>ruby dk.rb install


成功执行后就可以安装rails   gem install rails  ,   中途也可能报错,但是不影响安装,最后执行 rails -v 查看是否安装成功



最新文章

123

最新摄影

微信扫一扫

第七城市微信公众平台