docker中gem install json,提示"requires Ruby version ~> 2.0"

2016-11-05 19:30:52来源:CSDN作者:lieyanhaipo人点击

1.error installing: "requires Ruby version ~> 2.0"

docker镜像加载之后

查看ruby版本和irb版本

#ruby --version



如果不是2.0以上版本则需要安装ruby2.0

#apt-get install ruby2.0


更改ruby软连接

#ln -s /usr/bin/ruby2.0 ruby

更改irb软连接

#ln -s /usr/bin/irb2.0 irb

更改gem软连接

#ln -s /usr/bin/gem2.0 gem


如果还有如下错误,继续往下看

2.can't find header files for ruby at /usr/lib/ruby/include/ruby.h

有时候在ruby下使用gem安装包的时候,会报错如下:

     ERROR:  Error installing bluecloth:  
  ERROR: Failed to build gem native extension.  
  
/System/Library/Frameworks/Ruby.framework/Versions/2.1/usr/bin/ruby  
extconf.rb  
mkmf.rb can't find header files for ruby at  
/System/Library/Frameworks/Ruby.framework/Versions/2.1/usr/lib/ruby/ruby.h

  如果是在centos等系统下面,执行命令:yum  install   ruby-devel 

  如果是在Ubuntu等系统下面,执行命令:apt-get  isntall   ruby-dev


注意:此过程docker镜像不可以重新加载,因为镜像是只读的,重新加载之后恢复初始状态



最新文章

123

最新摄影

微信扫一扫

第七城市微信公众平台