RubyMine 2016.3 EAP,对 Puppet 的更好支持

2016-11-07 10:58:25来源:作者:开源中国人点击

RubyMine 2016.3 EAP 发布了, 该版本主要改进记录如下:

对 Puppet 更好的支持

首先,我们将默认语言级别更改为Puppet 4。您可以随时在 Settings | Languages & Frameworks | Puppet 中 调整它:

更智能的代码自动提示完成

对于所有主要的语法元素,例如 case , class , define , function , if , node , 和 unless, RubyMine 知道代码元素结构。

数据类型代码完成现在在类,函数和资源类型的参数列表中可用

代码完成现在可以正常工作,并为标题中的字符串数组定义资源:

内置变量和实例的列表现在是最新的:

Puppet 函数

RubyMine 现在支持定义 Puppet 函数,一旦定义,函数也可在代码完成中使用

点击查看发布说明 以了解更多, 点此查看完整更新列表 。

下载地址

RubyMine 是一个全新的为 Ruby 和 Rails 开发者准备的 IDE (非开源且收费),RubyMine 由 JetBrains 开发(JetBrains最著名的产品之一就是 Java IDE:IntellJ IDEA了!)。RubyMine 是建立在 IntellJ IDEA 平台之上,提供所有必须的 IDE 功能,比如编辑,调试工具,源代码控制集成,代码自动提示完成,以及其他功能。专门为 Ruby 打造的功能有基于 GUI 支持的 RSpec 和 Test::Unit。

最新文章

123

最新摄影

微信扫一扫

第七城市微信公众平台