CocoaPods 的安装

2016-11-11 20:04:47来源:CSDN作者:qian521kun521人点击

第七城市

到了家新司,拉代码的时候整理了下。

CocoaPods 的安装


gem是管理Ruby库和程序的标准包,如果它的版本过低也可能导致安装失败,解决方案自然是升级gem,执行下述命令即可:

    1、更换 Gem 的源,
        可根据自己的需求查看自己的gem版本,gem -v,
        可使用gem sources -l 查看自己源地址
        更换自己源地址
            gem sources --remove https://rubygems.org/
            gem sources -a http://ruby.taobao.org/
            gem sources -l


    2、更新升级 Gem 版本
        sudo gem update --system
        附加:gem install yourLib -v yourVersion
             gem uninstall yourLib -v yourVersion


    更多信息可访问:http://guides.rubygems.org


    3、安装CocoaPods
    可根据 pod --version查看自己pod版本,如果报错提示未安装,安装步骤
        先检查pod的源,国外的比较慢,改为国内pod源(大家都在使用淘宝的一个)
            执行1步骤,已经执行过就不需要再弄一遍了
        ok后,执行 sudo gem install cocoapods -v yourVersion


    如果已经安装过了需要替换版本,需要先卸载
    which pod 查找pod安装目录
    sudo rm -rf <path>  移除pod
    因为gem里已经有了pod库需要移除
    使用 gem list 查看
        gem list
        输出
    *** LOCAL GEMS ***
        activesupport (4.1.8, 3.2.21)
        bigdecimal (1.2.0)
        CFPropertyList (2.2.8)
        claide (0.7.0)
        cocoapods (0.35.0, 0.34.1, 0.34.0)
        cocoapods-core (0.35.0, 0.34.1, 0.34.0)
        cocoapods-downloader (0.8.0, 0.7.2)
        cocoapods-plugins (0.3.2)
        cocoapods-trunk (0.4.1, 0.2.0)
        cocoapods-try (0.4.2)
        colored (1.2)
        escape (0.0.4)
        fuzzy_match (2.0.4)
        i18n (0.6.11)
        io-console (0.4.2)
删除这俩
sudo gem uninstall cocoapods -v 0.35.0
sudo gem uninstall cocoapods-core -v 0.35.0即可


安装你想要的pod版本
sudo gem install cocoapods -v 0.34.4
安装成功后
$ pod --version
***************************next step:do you want*******************


自己工程如果未安装过pod 需要先为这个工程安装pod工程
cd yourProjectPatch
pod search yourLib
if you want to get more info ,do pod --help
第七城市

最新文章

123

最新摄影

微信扫一扫

第七城市微信公众平台