mac 安装pod步骤记录

2016-11-11 20:04:48来源:CSDN作者:u012091216人点击

  • 安装pod首先安装ruby,不过mac电脑已经安装好了ruby
    命令:ruby –version 查看版本

  • 安装brew
    命令:ruby -e “$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/install)”
    (有的博客写的是这个ruby -e “$(curl -fsSL https://raw.github.com/Homebrew/homebrew/go/install)”,这个返回的是404)
    Press RETURN to continue or any other key to abort
    (按回车键)

  • 安装rvm
    指令:curl -L https://get.rvm.io|bash -s stable
    指令:source ~/.rvm/scripts/rvm
    指令:rvm -v

    (我的版本是1.27.0)
  • 指令:rvm list known (列出已知的 Ruby 版本)

  • 指令:rvm install 2.3.0 (安装最新的版本)

    这里出现了点问题:
    No binary rubies available for: osx/10.12/x86_64/ruby-2.0.0-p648.
    Installing required packages: autoconf, automake, libtool, pkg-config, libyaml, readline, libksba, openssl….
    解决的方法是用brew 安装上述的包

    • 指令:brew install autoconf
      在这里又出现了一个问题:
      xcrun: error: active developer path (“/Applications/Xcode 2.app/Contents/Developer”) does not exist,
      use sudo xcode-select --switch path/to/Xcode.app to specify the Xcode
      that you wish to use for command line developer tools (or see man xcode-select)
      Error: Failure while executing: git config –local –replace-all homebrew.private true
      解决办法:
      指令:sudo xcode-select -s /Applications/Xcode.app/Contents/Developer
      分析:我安装过多个版本的xcode,系统默认的xcode路径是老版本的,所以需要更改下路径
      (注:有的博客写的指令是sudo xcode-select –switch path/to/Xcode.app,但我这没成功)
    • 指令:brew install automake
    • 指令:brew install libtool
    • 指令:brew install pkg-config
    • 指令:brew install libyaml
    • 指令:brew install readline
    • 指令:brew install libksba
    • 指令:brew install openssl
  • 指令:rvm list
  • 指令:rvm 2.3.0 –default
  • 指令:ruby -v
  • 指令:gem -v
  • 指令:sudo gem install cocoapods
  • 指令:pod –version

最新文章

123

最新摄影

微信扫一扫

第七城市微信公众平台