Could not find gem 'sqlite3 (>= 0) x64-mingw32' in any of the gem sou

2016-12-03 14:06:46来源:网络收集作者:Worker人点击

Could not find gem 'sqlite3 (>= 0) x64-mingw32' in any of the gem sources listed in your Gemfile or available on this machine.

Run `bundle install` to install missing gems.


在windows下搭建Ruby Rails Web开发环境时遇到这个问题,

出现此问题的原因是:没有安装sqlite3

安装sqlite3

执行命令:gem install sqlite3-ruby

[plain]view plaincopyC:/ruby>geminstallsqlite3-rubyFetching:sqlite3-1.3.11-x64-mingw32.gem(100%)Successfullyinstalledsqlite3-1.3.11-x64-mingw32Fetching:sqlite3-ruby-1.3.3.gem(100%)#######################################################Hello!Thesqlite3-rubygemhaschangedit'snametojustsqlite3.Ratherthaninstalling`sqlite3-ruby`,youshouldinstall`sqlite3`.Pleaseupdateyourdependenciesaccordingly.ThanksfromtheRubysqlite3team!<3<3<3<3#######################################################Successfullyinstalledsqlite3-ruby-1.3.3Parsingdocumentationforsqlite3-1.3.11-x64-mingw32Installingridocumentationforsqlite3-1.3.11-x64-mingw32Parsingdocumentationforsqlite3-ruby-1.3.3Installingridocumentationforsqlite3-ruby-1.3.3Doneinstallingdocumentationforsqlite3,sqlite3-rubyafter1seconds2gemsinstalled安装过程中可能会出现以下问题:

Could not find gem 'sqlite3 (>= 0) x64-mingw32' in any of the gem sources listed in your Gemfile or available on this machine.
Run `bundle install` to install missing gems.
" port 443 (https://api.rubygems.org/quick/Marshal.4.8/sqlite3-ruby-1.3.3.gemspec.rz)
这可能是由于网络的原因,多试几次就好了。



最新文章

123

最新摄影

微信扫一扫

第七城市微信公众平台