Unable to require openssl, install OpenSSL and rebuild ruby … on Ubuntu 14 LTS

2016-12-03 14:06:55来源:网络收集作者:管理员人点击

I followed the steps from http://rubyonrails.org/download/ to install ruby but ran into this error:


ERROR:While executing gem … (Gem::Exception)
Unable to require openssl, install OpenSSL and rebuild ruby (preferred) or use non-HTTPS sources
1
2
ERROR:While executing gem … (Gem::Exception)
Unable to require openssl, install OpenSSL and rebuild ruby (preferred) or use non-HTTPS sources
That’s what I did:


wget http://cache.ruby-lang.org/pub/ruby/2.2/ruby-2.2.2.tar.gz
tar xfvz ruby-2.2.2.tar.gz
cd ruby-2.2.2/
./configure
make
sudo make install

The next thing would be installing rails with


gem install rails

But this returned the mentioned error:


ERROR: While executing gem ... (Gem::Exception)
Unable to require openssl, install OpenSSL and rebuild ruby (preferred) or use non-HTTPS sources

From my google search I gained that this is a rather common error but none of the suggested solutions helped out of the box for my Ubuntu 14 LTS. The most important thing was installing the correct openssl devel package and not only openssl:


sudo apt-get install libssl-dev

While on it I also installed some other packages that threw errors in the prior make process


Vim


sudo apt-get install libssl-dev libreadline-dev libgdbm-dev

To get the ruby installation recognize everything that has been installed by the latest apt-get install best clean up before you do a second round of configure-make-voodoo:


make clean
./configure
make
sudo make install

Now you can install rails without any trouble:


sudo gem install rails

最新文章

123

最新摄影

微信扫一扫

第七城市微信公众平台