Mac OS安装brew出现错误的解决办法

2017-08-23 19:32:53来源:CSDN作者:yiifaa人点击

分享

Mac OS默认已安装好了ruby,所以可直接运行一下命令:

/usr/bin/ruby -e "$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/install)"

但是在安装过程中,会提示如下错误:

xcode-select: error: invalid developer directory'/Library/Developer/CommandLine Tools'

解决办法如下:
1. 从App Store安装Xcode软件;
2. 安装完成后,打开Xcode软件,接受licence;
3. 然后运行如下命令,确认Xcode的版本;

# 确认Xcode的版本ls -l /Applications/|grep Xcode
  1. 根据上面的结果,确定执行命令的目录;
#   Xcode.app就是上面过滤的结果sudo xcode-select -s /Applications/Xcode.app/Contents/Developer

最新文章

123

最新摄影

微信扫一扫

第七城市微信公众平台