Unable to require openssl, install OpenSSL and rebuild ruby (preferred) or use non-HTTPS sources

2017-10-13 12:51:38来源:CSDN作者:phxiang人点击

分享

mac os x 由于手动安装rvm导致了命令行一直报错 Unable to require openssl, install OpenSSL and rebuild ruby (preferred) or use non-HTTPS sources
经过不断尝试 使用如下方案解决

rvm get stable
brew update
brew doctor
brew install openssl
rvm reinstall 2.4.0 –with-openssl-dir=brew --prefix openssl (or whatever version)
rvm use (ruby version here) i.e. rvm use ruby-2.4.0
rvm gemset create NAME i.e. rvm gemset create rails41
gem install rails -v 4.1

最新文章

123

最新摄影

闪念基因

微信扫一扫

第七城市微信公众平台