android系统编译对jdk和make的版本要求

2018-02-27 11:54:19来源:oschina作者:球球人点击

分享
根据官网的资料
Java Development Kit (JDK)

Please note, since there are no available supported OpenJDK 8 packages for Ubuntu 14.04, the Ubuntu 15.04 packages must be installed manually. SeeJDK for Ubuntu LTS 14.04for precise instructions.

The master branch of Android in AOSP: Ubuntu -OpenJDK 8, Mac OS -jdk 8u45 or newer
Android 5.x (Lollipop) - Android 6.0 (Marshmallow): Ubuntu -OpenJDK 7, Mac OS -jdk-7u71-macosx-x64.dmg
Android 2.3.x (Gingerbread) - Android 4.4.x (KitKat): Ubuntu -Java JDK 6, Mac OS -Java JDK 6
Android 1.5 (Cupcake) - Android 2.2.x (Froyo): Ubuntu -Java JDK 5 Key packagesPython 2.6 -- 2.7 frompython.org
GNU Make 3.81 -- 3.82 fromgnu.org; Android 3.2.x (Honeycomb) and earlier will need torevert from make 3.82to avoid build errors
Git 1.7 or newer fromgit-scm.com

实测发现 make 4.1也可以用来编译Android N

最新文章

123

最新摄影

闪念基因

微信扫一扫

第七城市微信公众平台