安装PHP相关组件

2017-01-10 10:06:27来源:oschina作者:小小小小小胖丶人点击

根据之前上课的内容,按老师给的步骤去一一操作。因为没有拷贝老师给的repos.tar.gz ,所以多了不少波折。在安装依赖关系文件的时候都是不成功的,所以 更新YUM配置 的这一步骤是不必要的,因为课程需要,将老师给的需要安装的依赖关系文件都下载好:


yum -y install wget yum -y install gcc yum -y install gcc-c++ yum -y install pcre-devel yum -y install zlib-devel yum -y install libxml2 yum -y install libxml2-devel yum -y install libevent yum -y install libevent-devel yum -y install autoconf yum -y install libpng-devel yum -y install openssl-devel yum -y install curl yum -y install curl-devel yum -y install expat-devel yum -y install perl yum -y install perl-ExtUtils-MakeMaker yum -y install gettext-devel yum -y install zlib-devel yum -y install cpio yum -y install gettext-devel yum -y install ncurses-devel yum -y install bison yum -y install bison-devel yum -y install make yum -y install cmake


在之后的操作中,用 vim 时出现-bash: vim: command not found.


因为不知道该如何操作,就去查看了相关资料,输入rpm -qa|grep vim 命令可以查看缺少那些vim依赖组件,少了哪个可以补哪个,像我比较懒得,就直接输入yum -y install vim* 就全部下载了。


之后就成功打出了“hello world”,这虽然不是很难得过程,确实第一次比较有成就感的感觉。继续加油,努力学习!


最新文章

123

最新摄影

微信扫一扫

第七城市微信公众平台