【Yii2】Yii2执行完composer install 出现 vendor/bower/jquery/dist 找不到的解决方案

2017-01-13 10:53:06来源:csdn作者:diandianxiyu人点击

第七城市
问题

在我们的项目中,vender的部分不会放在文件仓库内,而是被忽略掉。

删除项目内的“vender“`文件夹
在项目根目录执行composer install
访问项目,出现报错

The file or directory to be published does not exist: D:/xampp/htdocs/basic/vendor/bower/jquery/dist解决

解决问题的关键在于升级composer到1.1.1,就不会出现对应的路径问题


/usr/local/bin/composer self-update//升级composercomposer global require "fxp/composer-asset-plugin:~1.1.1" //加载composer 的 1.1.1版本composer install //执行安装
出现问题的原因

原因在于中文官方文档没有及时更新

中文站

http://www.yiichina.com/doc/guide/2.0/start-installation

英文站

http://www.yiiframework.com/doc-2.0/guide-start-installation.html#installing-via-composer

总结
能看英文原版就看原版
需要看文档而不喜欢写文档的程序员被不喜欢写文档的程序员坑了
参考资料
https://segmentfault.com/q/1010000004047286
http://www.yiichina.com/doc/guide/2.0/start-installation
http://www.yiiframework.com/doc-2.0/guide-start-installation.html#installing-via-composer
第七城市

最新文章

123

最新摄影

微信扫一扫

第七城市微信公众平台