解决datagrip连接mysql8.0.4

2018-02-27 10:56:08来源:oschina作者:inuxor人点击

分享

公司的mysql8.0.3通过mysql官方源升级到了8.0.4。




然后各种远程管理客户端都废了。经调研,是jdbc的连接库不适合新版本的默认认证方式。




官方给出了新的mysql-connector-java-8.0.9-rc,可以解决这个问题。下面以datadrip为例记录一下踩坑经验。



系统环境

本例在ubuntu17.10,KDE plasma环境下有效,据信Windows 10也是有效的。远程数据库服务器为centos7,使用mysql官方yum源安装mysql8.0.4社区版。


下载并安装DataGrip(略)
下载mysql-connector-java-8.0.9-rc

Download Connector/J


解压缩到某个你能找到的地方,解压后的文件夹里面有一个mysql-connector-java-8.0.9-rc-bin.jar文件,等会要用的就是它。


开始设置
启动datagrip,file->data sources

data sources


复制一份mysql配置出来

duplicate

我把它改名为mysql 8.0

如图设置

如图设置


同一界面下,点击左上角加号,用mysql 8.0新建一个工程数据源
注意两个地方

注意1
注意2


保存并测试一下连接

测试连接

最新文章

123

最新摄影

闪念基因

微信扫一扫

第七城市微信公众平台