ubuntu 16.04 i386安装YouCompleteMe

2017-01-05 20:15:32来源:CSDN作者:xtydtc人点击

感觉vim就是缺一个自动补全,所以网上找了一阵子,装了YouCompleteMe这个插件。由于发现网上的很多安装教程比较老旧混乱,所以根据自己的安装经验在这里做一个总结,其实按照vundle和YouCompleteMe的github主页,安装过程还是比较简单的。

  • 如果没有git先安装git

  • 按照vundle里面的Quick Start逐步安装配置,然后得到如下.vimrc配置。
    这里写图片描述
    其中最后两行是让vim在启动的时候加载相关配置文件。

  • 启动vim运行“:PluginInstall”

  • 再解决一些依赖问题
sudo apt-get install build-essential cmakesudo apt-get install python-dev python3-dev

这里安装会很慢…跟网络好坏有很大的影响。

  • 增加对C族语言的语义匹配支持
cd ~/.vim/bundle/YouCompleteMe./install.py --clang-completer

到此为止就可用了。
这里写图片描述

参考:http://www.mamicode.com/info-detail-1596462.html

最新文章

123

最新摄影

微信扫一扫

第七城市微信公众平台