ubuntu RPM should not be used directly install RPM packages, use Alien instead!

2017-01-13 08:23:52来源:CSDN作者:shendixiaoxuan人点击

在Ubuntu中安装jdk rpm 出现错误,安装不上去,报错信息:

rpm: RPM should not be used directly install RPM packages, use Alien instead!rpm: However assuming you know what you are doing...error: Failed dependencies:	/bin/basename is needed by jdk1.8.0_40-2000:1.8.0_40-fcs.x86_64	/bin/cat is needed by jdk1.8.0_40-2000:1.8.0_40-fcs.x86_64	/bin/cp is needed by jdk1.8.0_40-2000:1.8.0_40-fcs.x86_64	/bin/gawk is needed by jdk1.8.0_40-2000:1.8.0_40-fcs.x86_64	/bin/grep is needed by jdk1.8.0_40-2000:1.8.0_40-fcs.x86_64	/bin/ln is needed by jdk1.8.0_40-2000:1.8.0_40-fcs.x86_64	/bin/ls is needed by jdk1.8.0_40-2000:1.8.0_40-fcs.x86_64	/bin/mkdir is needed by jdk1.8.0_40-2000:1.8.0_40-fcs.x86_64

查了一下原来是Ubuntu的软件包格式是deb,如果要安装rpm的包,则要先用alien把rpm转换成deb。

sudo apt-get install alien #alien默认没有安装,所以首先要安装它

sudo alien xxxx.rpm #将rpm转换位deb,完成后会生成一个同名的xxxx.deb

sudo dpkg -i xxxx.deb #安装

注意,用alien转换的deb包并不能保证100%顺利安装,所以可以找到deb最好直接用deb

有时候,我们想要使用的软件并没有被包含到 Ubuntu 的仓库中,而程序本身也没有提供让 Ubuntu 可以使用的 deb 包,你又不愿从源代码编译。但假如软件提供有 rpm 包的话,我们也是可以在 Ubuntu 中安装的。

方法一:

1. 先安装 alien 和 fakeroot 这两个工具,其中前者可以将 rpm 包转换为 deb 包。安装命令为:

sudo apt-get install alien fakeroot

2. 将需要安装的 rpm 包下载备用,假设为 package.rpm。

3. 使用 alien 将 rpm 包转换为 deb 包:

fakeroot alien package.rpm

4. 一旦转换成功,我们可以即刻使用以下指令来安装:

sudo dpkg -i package.deb

方法二:

1.CODE:

sudo apt-get install rpm alien

2.CODE:

alien -d package.rpm

3.CODE:

sudo dpkg -i package.deb


安装成功后,查询安装的目录命令   sudo dpkg -L 安装生成的文件名

配置环境变量   vi  /etc/profile 

source /etc/profile  即可


最新文章

123

最新摄影

微信扫一扫

第七城市微信公众平台