CentOS下Apache安装总结

2017-11-15 11:20:52来源:segmentfault作者:smallclover人点击

分享
CentOS下Apache安装总结
环境(Environment)

操作系统:CentOS 6.8
服务器:Apache 2.4.29
其他关键依赖库:apr 1.6.3、apr-util 1.6.1、pcre-8.41


命令(Command)
解压命令
























命令格式命令说明命令参数解释
tar zxvf [dir1] -C [dir2]将dir1下的文件解压到dir2指定的目录下
rpm -qa [software-name]查询指定的软件
rpm -e --nodeps [software-full-name]卸载指定名称的软件--nodeps:不做软件之间的依赖检查
./configure --prefix=[dir] --with-[lib]--prefix:指定安装目录--with-[lib]:依赖(个人理解)
Apache安装
编译安装(make install)问题(problem)























































发生时间错误内容解决方案(个人)解决方案(网络)权重
Apache 安装时error:Cannot use an external APR with the bundled APR-util对apr-util重新进行编译安装Google
Apache 安装时error:Did not find pcre-config script at [dir]将pcre2替换为pcre,然后进行编译安装Google
pcre安装时error: You need a C++ Compiler for C++ SupportGoogleyum install -y gcc gcc-c++
Apache 安装时error:pcre-config for libpcre not found在./configure 配置时使用--with-pcre=[dir]指定pcre安装目录重新安装或者第一次安装pcre
Apache 安装时error:no acceptable C complier found in $PATHGoogleyum -y install gcc
apr-util 安装时(一部分错误提示)error:'apr_xml_parser' has no memebr named 'xp'
Googleyum install expat-devel
Apache 安装时(一部分错误提示)error:openssl version is too old
Googleyum install openssl-develyum update openssl

第一次编写这种总结,如有不对之处,欢迎dalao指出(给dalao递女装)。

最新文章

123

最新摄影

微信扫一扫

第七城市微信公众平台