CentOS6.9升级autoconf版本,解决”Autoconf version 2.64 or higher is required“错误

2018-02-08 19:01:57来源:cnblogs.com作者:lokion人点击

分享

安装软件时提示说需要Autoconf 2.64或更高的版本:

1 # autoconf  2 configure.ac:8: error: Autoconf version 2.64 or higher is required  3 configure.ac:8: the top level  4 autom4te: /usr/bin/m4 failed with exit status: 63 

查询当前版本:

1 # rpm -qf /usr/bin/autoconf  2 autoconf-2.63-5.1.el6.noarch  

卸载当前版本:

1 # rpm -e --nodeps autoconf-2.63

安装最新版本:

1 # wget https://ftp.gnu.org/gnu/autoconf/autoconf-2.69.tar.gz2 # tar zxvf autoconf-2.69.tar.gz  3 # cd autoconf-2.69  4 # ./configure5 # make && make install  

查看当前版本:

1 # /usr/bin/autoconf -V  2     autoconf (GNU Autoconf) 2.69  3     Copyright (C) 2010 Free Software Foundation, Inc.  4     License GPLv3+/Autoconf: GNU GPL version 3 or later  5     <http://gnu.org/licenses/gpl.html>, <http://gnu.org/licenses/exceptions.html>  6     This is free software: you are free to change and redistribute it.  7     There is NO WARRANTY, to the extent permitted by law.  8       9     Written by David J. MacKenzie and Akim Demaille.  

至此,autoconf已升级到2.69

最新文章

123

最新摄影

闪念基因

微信扫一扫

第七城市微信公众平台