github不支持tlsv1.1后, 出现SSL connect error

2018-02-23 21:13:10来源:cnblogs.com作者:Fahy人点击

分享

    过完年回来, github不安分了, 发了博文说不支持TLSv1/TLSv1.1: Weak cryptographic standards removed, 没看到这篇博文之前, 还以为是代理问题, 设置过, 还是不行, 还更新到最新的git, 还是不行, 就查了一下TLS协议, 终于通过git的文档中获得提示: git配置文档.

    首先, 更新git, 我也没查过要更新到什么版本, 反正之前用1.8有问题, 接下来的操作都不起效, 换了2.16以后才可以, 有条件就更到最新呗. 至于怎么更新, 自己查资料, 我就不喜欢惯着你们. PS:OpenSSL和libcurl可能也要升级

    然后就开始设置了, 就一行命令

git config --global http.sslversion tlsv1

    理论上来说, 应该是不支持TLSv1的, 但设置成tlsv1才行, 其他的tlsv1.2什么的都不行, 我也不知道啊, 求指教, 求科普

    因为是刚找到的方法, 也许其他大神还没有发现这问题, 如果有更好的办法, 请不吝指教.

最新文章

123

最新摄影

闪念基因

微信扫一扫

第七城市微信公众平台